Unable to understand the compilation error here.

I have the following submission in scala for one of the practise questions at http://www.codechef.com/problems/INTEST/ and I keep getting compilation error. I compared it with other submissions and I just have a few lines of difference. But I still get a weird error. Please help.

object Main {
   def main(args: Array[String]) {
      val inputs = readLine.split(" ")
      val n = inputs(0).toInt
      val mod = inputs(1).toInt
      var sum = 0
      for (i <- (1 to n))  {
         var myvar = readInt
         if (myvar % mod == 0) sum += 1

Here is the compilation error.

1 Like

it is running perfectly on ideone…LINK!!!

There have been some issues with the SCALA judge lately…maybe that is why u r getting a compile-time error…:slight_smile:

1 Like

Thanks for the answer!!! How do you report this issue?

send a mail to bugs@codechef.com or feedback@codechef.com …!!!

Ah the error still persists. I tried after like a month and stil get the error http://www.codechef.com/view/error/2595921/ .

I have emailed them. There is no response from them.