Sub-task 2 of DIVMAC

The question clearly mentions of a sub-task 2 in the problem statement while it shows none after submitting. Am I missing something here or is this a temporary error?

EDIT: The problem is now fixed, but they took a long time to do that. Also the announcement was made late.

1 Like

I have not solved the problem but yes there are submission with only 10 or 100 points. If there was subtask 2, then 25 and 35 points should have been there.

1 Like

They were not added before, i also commented for the same, seems they have updated and added more test cases now, Time limit for the problem has been reduced to 1-3 sec. Solutions haven’t been rejudged but i think they will later, another sample output has been added to clarify output format, also for second sample test case output should be 2 and not 1.

1 Like

Are comments blocked for some reason?
I have been posting a few but a friend mentioned that none of them are showing up.

Posting them here hoping they see it:

doodhwala 2 hours ago
@kaizer @dppraveen_admin The sample output for the second test case should be 2

doodhwala 15 hours ago
@kaizer You may want to look into the time limits for Python 2 and 3 It is really annoying if you keep trying to improve your solution but realise that the problem is with the language and not the algo Thanks :slight_smile:

doodhwala 5 hours ago
@kaizer, @admin … Don’t know what you guys did but now the same code that solved subtask 1 in 0.1s is giving TLE And from three rows, the submissions are now showing 10 rows

doodhwala 5 hours ago
Refer to submissions: 11372149(TLE) and 11362677(AC)

doodhwala 3 minutes ago
@kaizer @dppraveen_admin Time limit has been reduced instead of increased (25 to 15) And older submissions haven’t been rejudged. Hence, submission no (11348735 12:09 PM 04/09/16 sherlock1996) has gotten 100 points with 19.61s But submission no (11374745 24 min ago doodhwala) times out at 15s itself

1 Like

Can somebody explain the second test-case?
given A = {2,3}
Query = 0 2 2
so A should become {2,1}
Query = 1 1 2
Answer should be 2 , but 1 is given in the sample output

I have also commented on the question, but dont know why it’s still not published.

1 Like

codechef please tell us our solutions will be rejudged or not .thanks

1 Like

The correct answer is 2 only.

Also in the second subtask , not all numbers are prime . Will they change the test cases ?

EDIT : Now the 2nd subtask consists of only primes

2 Likes

codechef is not answering queries related to the problem.we are in suspense .codechef,please make it clear

3 Likes

@doodhwala the problem can be solved using python within given time frame(mine worked in 6.66 :frowning: ), not sure with PYTH 3.1.2, but i suggest you to change the code to python2, that will take less than 15 min, and try running it with PYPY instead of python2(it should work almost fine), don’t know whether given PYPY interpret PYTH 3.1.2 code or not, so first try with PYTH3.1.2.

1 Like

@ashwanigautam

Thank you so much. I learnt about Pypy from you

I got 2 tasks out of 3 now. But more importantly, I got a benchmark and some drive to try more :slight_smile:

PS - Not enough rep to comment/upvote

1 Like

they made changes in problem but announcement is not made yet.Dear chef customers are waiting.please recook half cooked and uncooked problems.thanks

1 Like

it’s been more than 24 hrs what’s happening there is no announcement about the 5th problem isn’t this serious.@admin tell us about rejudging of solutions.

There is no error.I scored 25 points in DIVMAC.Please read the subtasks again carefully.

you need test cases or asking what’s wrong in my code here it is https://discuss.codechef.com/questions/18662/does-codechef-have-any-code-of-conduct.:-|

thanks mahipalsaran for clearing that up :slight_smile:

//