Problem in C++ IDE in UBUNTU (Linux)

I installed Code::Block 12.11-2 in my Ubuntu (linux) system.

But i am not able to compile my programs written in C++/C.

Any body using Code::Block in linux please help me OR you can suggest me a good IDE for C/C++ programs in Ubuntu .

Happy Coding !!!

Have you tried geany?


It is available in the software centre.

I am installing it … thanks @tijoforyou


My pleasure!

have you configured path of code::block to your g++ library or executor for compile source code?

1 Like

I don’t know how to configure its path …

1 Like

Do we need to configure something in geany … because after installation i tried to write code and again same problem … not able to compile.

AFAIK, there is no need of any configuration.

First, you press the compile button. Then, you press the build button. Then, you press the execute/run button. (Press the three buttons from left in the order they appear :smiley: )

Something like this:

Btw, you need to have g++ installed in your system.

1 Like

Hello @upendra1234,

I’ve used Codeblocks once and I hated it… Now I use Geany and it all works much better…

However, it seems to me you might have a linkage problem with your IDE configurations…

I suggest you the following thing for starters. Let’s compile a simple program via command-line usage:

Write a trivial “Hello World” program in a text editor, like gedit and save it as hello.cpp on Desktop or so…

Then fire up the Terminal (shortcut Ctrl-Alt-T in Ubuntu) change your current directory to desktop (usually type “cd Desktop” only) and compile the program directly on the terminal:

g++ -o hello hello.cpp -lm

(this should work without any errors or warnings)

And then do simply:


to execute it… If this works without any errors, we can fix your problem easily…

Otherwise, something might be wrong or misconfigured with your compiler…

Tell me how this works out for you… :slight_smile:

Best regards,

Bruno Oliveira

Thanks guys for you kind information… I was missing g++ in my system … Now i have installed it and my all compilers are working fine…
Both Code::Block and Geany …

Thanks @tijoforyou , @kuruma @thuvh

1 Like

That’s good to know :slight_smile:
And a tip, when in doubt about something being installed on your system or not, the terminal is your best friend, ALWAYS :wink:

1 Like

if u want to use auto-complete, u can try sublime…

You may also want to use vim.Try it,you wont regret.:slight_smile: