JAVA submissions RE

It seems like all java submissions are getting runtime errors for some time now. I even submitted one of my ac solutions in one of the problems and it gave RE. Tried INSTEST and TEST (with previous ac solution), still RE… Please look into this, I made sure this wasn’t because of my approach or something like that…

Yeah facing the same problem here. Tried using try and catch(as this helped me earlier when facing the same issue) but to no avail this time.

@junior94 : Just checked your submission for “Enormous Input Test” . You have written a function called “nextInt” which reads one line of input and then calls Integer.parseInt() , however in this problem , the first line of input will contain two space seperated integers n and k , so if you use readLine() you have to tokenize it .

Also you are calling nextInt() seperately for reading n and k , and are hence using two lines of input while they appear on the same line .

1 Like

@vineetpaliwal I wrote those methods exactly for those kind of situations. I did test that solution. I have two separate functions for reading integers: nextInt() and readInt(). readInt() parses the whole line while nextInt() only reads the next integer (in the same line or in the next line). So even though it seems like in the first line of input the program is reading two lines it actually is reading one line. I don’t have enough space in this section to explain it all but pay attention to the methods declarations. I am using those methods for a long time, I know their pitfalls :slight_smile:

But thanks… I just tried again with a different problem with one of my ac solutions without changing anything and its still RE. If you could submit and see if you’re facing the same problem that would be highly appreciated.

Yeah I tried that too and nothing… For one of the problems I tested for all possible values in my machine and it could run without throwing any exceptions…

@junior94 : I resubmitted my own accepted solution to this problem and it is giving runtime error . Am writing to and


Thanks… I went to and noticed that the problem TACHEMIS in the medium section had ac solutions even after this issue has started. Perhaps codechef is updating the jdk and the jre. It’s the first time I’m seeing jdk 1.7 under submissions. It’s very unlikely that this is the problem but it is the only reasonable explanation I could come up with.

There has been an upgrade of the java compiler, and the issue be because of that. We are still investigating. We will update you soon. Regret the inconvenience.

1 Like

The issue has been fixed. If you still face any issue do let us write to us at

1 Like