How to add bits/stdc++.h in Dev C++

I guess the #inlude<bits/stdc++.h> is not present for Dev C++. Can anyone please help me out?
Is there anyway in which we can do it manually?

1 Like

not sure, but still suggest you to look at here:

Dev-C++ should use g++, right? It should be possible to include it directly by typing


(not with a billion typos like you did)

If it doesn’t work, try installing Cygwin (I suppose you’re on Windows) and compiling there.

1 Like

Yea i am using Windows…
The problem is that it seems like that this Dev C++ has not been updated since it has been created…So even though it is g++ the bits/stdc++,h is not included in the header file list…I asked is there any-way in which we can create our own header file…I know it is possible…but don’t know how it is done…:frowning: shall i just create a header file of this name and add all the header files there and save it in the bin folder and simply call in the programme ??

then here

You could. Or, as I said, you could just install Cygwin, which does have that header file, and compile with it instead of Dev-C++.

bits/stdc++.h is only usable in GCC versions (around > 4.2 or something like that).

That being said latest mingw (GCC’s windows port) does have that option.

So either install and IDE that uses latest mingw by default (for example : CodeBlocks) or install devCPP and then seperately download latest mingw and install it (it’s easily googlable how to do).

Another option is installing Cygwin which comes with GCC.

PS Note that your problem has nothing to do with devcpp, it only has to do with the fact that devcpp (probably) uses ancient version of mingw by default.


could you please explain me the use of this library:-#inlude bits stdc++.h="".

It includes all the necessary header files check in this link

We need not add all the header files while taking part in a contest.This will help us save time…
Happy Coding